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WeFax for Windows for Kantronics TNCS

Welcome to WeFax for Windows

Welcome to WeFax for Windows, the industry’s benchmark in Weather Facsimile download
software.  WeFax for Windows is a stand-alone application operating on the Windows ’95,
Windows ’98, Windows ME, Windows NT, Windows 2000, and Windows XP operating platforms.
Its purpose is to receive weather maps, transmitted by various shore stations around the world,
and pass them on to you.  WeFax for Windows is the only weather fax program on the market that
supports the Windows operating systems discussed above.  It is due to this fact that you will find
WeFax for Windows graphically oriented and easy to use.  We at Creative Services Software
would once again like to thank you for your purchase.

Introduction to WeFax for Windows
Installation of WeFax for Windows
Starting WeFax for Windows
Technical Support

Introduction to WeFax for Windows

WeFax for Windows requires several pieces of equipment for effective operation:

At least a short wave receiver capable of receiving Single Side Band (SSB) transmissions.  The
better you select your radio, the better the quality of the received transmission.

1) A personal computer capable of supporting Windows ’95, Windows ’98, Windows ME,
Windows NT, Windows 2000, and Windows XP.

2) Version 5.0 firmware or better for the KPC series or version 7 or better for the KAM series of
Kantronics TNCs.  The following TNCs support WeFax Mode: KAM E, KPC-1, KPC-2,
KPC-3, KPC-4, KAM Plus, KAM 98, KAM XL, and the KPC-2400.

Installation of WeFax for Windows

If you received a CD:

1) Insert the CD into your CD drive, and wait for the AutoRun program to start.

2) Follow the instructions on the screen to install WeFax for Windows for Kantronics TNCs.
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If you received diskettes:

3) Insert Disk one of your WeFax for Windows installation set into your 3.5” disk drive.

4) Once you have completed step one, click on the Start button.   This button is

typically located in the bottom left hand corner of your screen.

5) Select the Run option from the Start menu, then type: ‘A:\ setup.exe’ in the area of the Run
box labeled Open.  After this step is completed click the OK button displayed in the bottom of
the Run box.

6) The computer will begin the installation procedure after completion of step Three.  Follow
any instructions the computer gives you in order to complete the installation process.

Starting WeFax for Windows

After you have run the installation program, you are ready to start using WeFax for Windows.
There are two easy ways to start WeFax for Windows:

7) The first way to start WeFax for Windows is to double click on the WeFax for Windows icon
you chose to locate on your desktop during installation.  This is what the icon looks like.

8) The second way to start WeFax for Windows is to click on the Start button.  Following this
go to Programs.  Then the WeFax for Windows folder the click on WeFax for Windows.

The first time you start WeFax for Windows, you will receive the text box below, informing you
that you need to set your TNC settings.
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After clicking the OK button in the box above the communications setup window appears.  This
window allows you to modify your current communications settings.  You will need to set the
COM port where your TNC is connected and the baud rate of the TNC.  If you are not sure of the
baud rate set in your TNC, type ABaud in HyperTerminal before opening WeFax for Windows.



WeFax for Windows - 4

The WeFax Window

After starting WeFax for Window the following screen should have appeared in your monitor:

This is the main screen that you will use to receive WeFaxes.  You can note the toolbar near the
top of the screen, which gives you easy access to most of WeFax for Windows functions.  Go to
the Toolbar section for more information on the Toolbar.  Below the Toolbar is your WeFax
Receive window.  Below that window is the Monitor window showing commands that have been
issued to the TNC.  The bottom window is the Command window where you can manually enter
commands for the TNC.

Also at the top of the screen are the menu items.  You can access everything in WeFax for
Windows through the menus.
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Demo Mode

Demo Mode is a trial version of WeFax for Windows, which allows you to try WeFax for Windows
before you purchase it.  Some functionality has been taken out of Demo Mode.  You will not be
able to change the background and foreground colors or the font.  The ability to cut, copy and
paste text has been taken out in the unregistered version.  Also you will not be able to print or save
the bitmap after you have received it.  Lastly, a box of text asking you to register your software
will appear over the incoming WeFax.  A picture of what you can expect is shown here.
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Once you have purchased a serial number and activation key to activate all the features of WeFax
for Windows, simply click on the Help menu and then choose Registration.  You will then see a
screen similar to the one below where you enter your call sign, serial number, and activation key.

Simply type in your call sign, the serial number, and the activation key, and click OK.  If you want
to see the registration screen every time you start WeFax for Windows, click the box beside “Show
this window at startup.”  You will then be able to enjoy WeFax for Windows with all its
functionality.   If you are only using WeFax for Windows in Demo Mode, type in your call sign and
click the Demo Mode button.

What is a WeFax

WeFax pictures, or weather faxes, are maps that contain a summary of weather conditions,
showing such things as atmospheric pressure and surface temperatures over wide areas.  Many of
these maps show whole continents or oceans.  The HF station that transmits them often produces
these maps, but occasionally a HF station will receive satellite pictures and will transmit them over
the HF bands.
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Tuning the Radio

To effectively utilize the facsimile capabilities of WeFax for Windows simply tune your radio to a
Weather Fax transmitting station and then click on the WeFax toolbar button near the top of your

WeFax for Windows screen .  Once you have enabled the WeFax mode all you have to do is

wait for your map to appear on your screen.  There are over 50 Weather Fax transmitting stations
around the world.  Some of these stations are on a consistent transmission schedule and others
broadcast irregularly.

The first thing you need to do is tune to a WeFax station.  Because of limitations in the Kantronics
TNCs, there will be no lights on the front of the TNC that will tell you when you are tuned
correctly; you will have to tune manually.  The WeFax Signal sounds like a RTTY signal so if you
can tune those you shouldn’t have too big of a problem.  To start with, tune to the frequency as
best you can.  If you see more black then white on the incoming picture then you have tuned to
high.  If you see more white than black then you have tuned too low.  Adjust accordingly until you
reach an acceptable picture quality.

Here is an example of a WeFax picture from a poorly tuned or weak signal.  This picture is an
extreme but it will give you a general idea of what you don’t want.
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Kantronic’s TNCs and WeFax

Because the KAM sends WeFax data in a streaming format, detection of the start tones, stop
tones, and sync tones must be done manually.  This is a limitation of the firmware in the Kantronics
TNCs and not WeFax for Windows.

To use WeFax for Windows you will need a Kantronics TNC with 5.0 firmware or better.  The
following TNCs support WeFax Mode: KAM E, KPC-1, KPC-2, KPC-3, KPC-4, KAM Plus,
KAM 98, KAM XL, and the KPC-2400.

To receive WeFax you need to connect an audio cable from your receiver to the audio input of
your TNC.  For the KAMs this is the VHF port.
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Tech Support

If you need more information on Windows, please consult your Windows Help, available from the
Windows Start button.

For telephone support call (256) 381-6135.

For Support by email write support@cssincorp.com.

You can also check our web site for information.  Our web site is http://www.cssincorp.com.

Email problems with WeFax for Windows documentation to docmaster@cssincorp.com.

If you need more information on your TNC, please consult your TNC Owners Manual.
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WeFax for Windows Menus

File Menu

File Menu Options

The File Menu gives you access to file commands such as New, Open, Save, Save As, Print, and
Send.  It also allows you to access your program Settings and Exit the program.

New

The New command opens up a blank bitmap to receive a WeFax.  The size of this new bitmap is
determined by the resolution set in the setting’s screen.  See WeFax Settings for more information.
To open a new bitmap, click on the File menu and then choose New.

Shortcuts:

Toolbar button: 

Open

The Open command allows you to open an existing bitmap in your default bitmap viewer (for most
Windows users this will be Microsoft Paint).  To open an existing bitmap, click on the File menu
and then choose Open.



   WeFax for Windows - 11

Shortcuts:

Toolbar button: 

Save

The Save command allows you to save a WeFax once you are finished receiving it.  It is best to
pause or stop the transmission before you save it so that no new data will be coming onto the
screen while you are saving.  To save a bitmap, click on the File menu and then choose Save.

Shortcuts:

Toolbar button: 

The Save As command is the same as save but it asks you to put in a name for the bitmap every
time you click it and does not save over the existing bitmap of that name automatically.

To use the Save As command click on the File menu and then choose Save As.  There is no button
on the toolbar for Save As.

Print

The Print command allows the user to print the bitmap that is in the WeFax window of WeFax for
Windows.  To print the bitmap, click on the File menu and then choose Print.

Shortcuts:

Toolbar button: 

Settings

The Settings option gives you access to the WeFax for Windows program settings for
Communications settings, WeFax image settings, and WeFax program options.
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Communication Settings

The Communications Settings allow you to change the Communications port (COM port) where
the TNC is connected to the computer.  It also allows you to change the TNC Baud Rate setting.

The baud rate tells WeFax for Windows what the baud rate is on the TNC.  The baud rate on the
TNC and the WeFax for Windows must match.  To change the baud rate on your TNC you must
use the ‘Abaud’ command (without the quotes) and then change the baud rate for WeFax for
Windows to match the new baud rate in your TNC.

WARNING:  WeFax for Windows may not start properly if the baud rate of the TNC does
not match the baud rate in the Settings screen.

The Communications Settings screen also allows you to change your Mark and Space.
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WeFax Settings

The WeFax Settings window allows you to change the length and width of the received picture.
This dictates the file size of the finished bitmap when you save your picture.  The larger the
selection on this screen, the larger your saved file will be.  You also have the option with the KAM
’98 to receive WeFax in 16 shades of gray, 16 colors, or black and white.



WeFax for Windows - 14

Option Settings

The Options window allows you to change optional settings for WeFax.

Wrap - Allows a WeFax to wrap back to the top of the picture when a incoming picture reaches
the maximum lines you set in the WeFax settings.  If not checked, WeFax for Windows stops
displaying the picture when max lines is reached.

Lines Per Minute - Allows you to adjust the lines per minute to receive different types of
images.

Default Directory - Allows users to set a directory to store saved bitmaps.

Send

After you have received a WeFax you can click on the File menu and then choose Send to send the
picture as an attachment to an e-mail.  This command will automatically use your default mail
client (i.e. Internet Mail, Outlook, Outlook Express, Eudora, or Netscape Mail).
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Exit

The Exit command closes WeFax for Windows.  Use this command when you are finished with
everything you wish to do.  WeFax for Windows does not ask you if you want to save the open
Bitmap at the time you quit.

WeFax for Windows automatically sets the Maxusers to 10 for 1 port TNCs and 10/10 for 2 port
TNCs on exit.  And if you have the menu option checked to Return to Terminal Mode on Exit,
WeFax for Windows will return your TNC to Terminal Mode.

Edit Menu

Edit Menu Options

The Edit menu allows you to Cut, Copy, and Paste material in WeFax and also allows you to Undo
any changes.

Undo

Undo allows you to undo the last change you made.  For instance if you pasted a sentence into the
terminal window but you put it in the wrong place, you could Undo it instead of deleting it.  To
Undo something click on the Edit menu and then choose Undo.

Shortcuts:

Key Combination:  <Ctrl-Z>
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Cut

The Cut command will cut out a highlighted area and place it in the clipboard so you can paste it
later.  To cut a selected area of highlighted text, click on the Edit menu and then choose Cut.

Shortcuts:

Toolbar button: 

Key combination:  <Ctrl-X>

Copy

The Copy command will copy a highlighted area and place it in the clipboard so you can paste it
later.  To copy a selected area of highlighted text, click on the Edit menu and then choose Copy.

Shortcuts

Toolbar button: 

Key combination:  <Ctrl-C>

Paste

The Paste command will place the contents of the clipboard into the terminal window of WeFax
for Windows wherever the cursor is flashing.  To paste to the terminal window, click on the Edit
menu and then choose Paste.

Shortcuts

Toolbar button: 

Key combination:  <Ctrl-X>
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View Menu

View Menu Options

The View menu allows you to customize the appearance of WeFax for Windows.  You can select
whether to view the Toolbar or Status Bar.  You can also select an option to Return to Terminal
Mode when you exit WeFax for Windows.

Toolbar

In the View menu at the top of the WeFax window you can click on the Toolbar selection to
remove the toolbar from the screen.  To add it later just click on the View menu again and reselect
Toolbar so that a check mark appears beside Toolbar.

This is the WeFax for Windows Toolbar.  This selection of buttons puts the majority of WeFax for
Windows menu options at your fingertips.  Moving your mouse pointer over each button in the
program will give you the name of each one.

  The New button prepares to receive a new WeFax picture.  NOTE: As of this Preview, when

you click on the New button the program will not ask you to save your existing picture.  This will
be changed in future releases.

  The Open button opens an existing bitmap.  NOTE:  This command opens the bitmap in

Microsoft Paint, which comes standard with Windows 95, 98, ME, NT, 2000, and XP.

  The Save button allows you to save a WeFax picture to your computer.

  The Cut button cuts out any highlighted text and places it in the Windows clipboard.

  The Copy button makes a duplicate copy of the highlighted text and places the copy on the
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clipboard.

  Paste allows you to place any text that is in the clipboard on to a selected area on the

Terminal window.

  The WeFax button starts and stops receiving a WeFax Transmission.  Make sure that your

radio is tuned to the proper station before you begin receiving the image or you will only be
receiving noise.  You will know that you are not tuned in properly when your picture begins to
look like a still picture of a television set with ‘snow’ on it.

  The Pause button pauses receiving the WeFax picture.  The picture continues to be processed

in the background, but the picture stops coming onto the screen.  Because the program continues
to process the signal from the radio, when you unpause WeFax, the picture will automatically be
updated with the picture that was received while the program was paused.  This can be a problem
if you hold the WeFax paused too long.  Because the TNCs only have a finite buffer in which to
hold data, if you keep the WeFax paused too long then you may loose some of the data when you
unpause it.  The pause function is useful to use before you save or print an incoming bitmap.
When a picture is finished, pause the transmission and save or print your bitmap.  If you fail to do
this then the repeated fax may overwrite the completed picture.

  The Sync Left 10 Pixels button moves the sync line to the left 10 Pixels.

  The Sync Left button moves the sync line to the left 1 pixel

  The Sync Right button moves the sync line to the right 1 pixel

  The Sync Right 10 Pixels button moves the sync line to the right 10 pixels

*The sync line represents the left side of the WeFax.  The ability to move this line left or right
allows you to center the picture on different places on the incoming transmission.

Status Bar

In the View menu at the top of the WeFax window you can click on the Status Bar selection to
remove the status bar from the screen.  To add it later just click on the View menu again and
reselect Status Bar to put a check mark beside Status Bar.

On the left part of the Status Bar, it will tell you what you have your mouse pointer over.  For
instance, if you had it over the Cut Button on the toolbar, it would tell you that it was the cut
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command.  The Status Bar also let’s you know the time and whether you have the Num Lock,
Caps Lock or Scroll Lock on.  The Status Bar also tells you what mode you’re in (Terminal or
Host Mode) and the Dimensions in WeFax mode.

Return to Terminal Mode on Exit

Putting a check mark beside this option causes WeFax for Windows to put your TNC in Terminal
Mode when you exit the program.  If it is not checked, the TNC remains in Host Mode.

Tools Menu

Tools Menu Options

The Tools menu allows you to access the Fax Scheduler and the Image Viewer.

Fax Scheduler

This command allows you to set a predetermined schedule to download Weather Faxes.  You
should see a window that looks like this on your screen.
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You can set up to 10 schedules at a time for WeFax for Windows to remember.  In order for the
scheduler to work you must keep WeFax for Windows running.  With the scheduler you just set
the time that a transmission is set to commence and WeFax for Windows will automatically switch
to WeFax mode when that time arrives and switch off at the time you specified to stop.

Next to each schedule is a box.  Just click in the box to activate that schedule.  Once active you
may choose if you want to automatically receive a WeFax Once, Hourly, or Daily.  If you choose
‘Once’ then the Scheduler will only receive the WeFax one time and then stop.  If you choose
‘Hourly’ then it will automatically start and stop on the Date and Time that you have set and will
reset itself to the next Hour from the start time.  So after the transmission is received it will
increment both the start and stop times by one hour.  If you choose ‘Daily’ then the Start and Stop
time will begin as you set and when it is finished it will increment the Day by one.

AutoSave Default Directory – This allows you to set the directory that the Fax Scheduler saves
the received weather Facsimiles into when the stop time has been reached.  The file name that the
received WeFax is saved as is made up of the month, day, hour and minute of the start time.  For
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example if you started a reception on December 1st, 1999 at 12:45 UTC then the filename would
be 12m1d12h45.bmp

NOTE:  IF YOU USE THE SCHEDULER THEN YOU WILL WANT TO UNCHECK
THE ‘WRAP TO TOP’ OPTION IN THE OPTIONS SETTINGS WINDOW.  THIS WILL
PREVENT THE PROGRAM FROM COPYING OVER THE RECEIVED
TRANSMISSION IF YOU SET THE STOP TIME FOR LONGER THAN IT TAKES TO
RECEIVE THE TRANSMISSION.

Image Viewer

The Image Viewer allows you to view a received WeFax in an environment where you can Zoom,
Rotate, Flip and otherwise manipulate the picture.  If you have already received a picture in WeFax
for Windows and it is on your screen then simply click on Tools and then choose Image Viewer
and it will open the current picture in the Image Viewer.  If you have already saved the image and
simply want to view it again, open up Image Viewer the same way as above.  You should see the
following screen.

Simply click on the File menu then Open and choose the bitmap you want to view.

All commands in the Image Viewer are accessed through the right mouse click menu (see the
picture above for an example).  From the right-click menu you can Zoom in and out of the bitmap,
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Rotate it 90 degrees or 180 degrees in both clockwise and counter-clockwise directions.  You can
also Flip the image along its vertical or horizontal axis.  You also can change the alignment so it is
shown on the left, center, or right side of the window.

WARNING: IF YOU HAVE A CHECK MARK NEXT TO ‘FIT TO SCREEN’ THEN
YOU WILL NOT BE ABLE TO ZOOM IN OR OUT.  SIMPLY UNCHECK THE BOX
TO BE ABLE TO ZOOM AGAIN.

WeFax Menu

WeFax Menu Options

The WeFax menu gives you options for controlling WeFax picture reception.  Options include
Start WeFax, Pause WeFax, Sync, and Lines to Skip.

Start WeFax

Start WeFax signals WeFax for Windows to begin receiving a Weather Facsimile.  Make sure that
your radio is tuned to the proper station before you begin receiving the image or you will only be
receiving noise.  You will know that you are not tuned in properly when your picture begins to
look like a still picture of a television set with ‘snow’ on it.

Pause WeFax

This command will pause the incoming WeFax.  Remember though that this only pauses the
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display.  The signal will still be transmitting at the originating station.  While it is paused the
picture continues to be processed in the background, but the picture stops coming onto the screen.
Because the program continues to process the signal from the radio, when you unpause WeFax,
the picture will automatically be updated with the picture that was received while the program was
paused.  This can be a problem if you hold the WeFax paused too long.  Because the TNCs only
have a finite buffer in which to hold data, if you keep the WeFax paused too long then you may
loose some of the data when you unpause it.  The Pause function is useful to use before you save
or print an incoming bitmap.  When a picture is finished, pause the transmission and save or print
your bitmap.  If you fail to do this then the repeated fax may overwrite the completed picture.

Sync

Sync Left - This command moves the Sync line to the left one (1) pixel.

Sync Right - This command moves the Sync line to the right one (1) pixel.

Sync Left 10 Pixels - This command moves the Sync line to the left ten (10) pixels.

Sync Right 10 Pixels - This command moves the Sync line to the right ten (10) pixels.

*The sync line represents the left side of the WeFax.  The ability to move this line left or right
allows you to center the picture on different places on the incoming transmission.
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Lines to skip

The Lines to Skip option increases or decreases the resolution of the picture.  Increasing the
number of Lines to Skip decreases the resolution.  Decreasing the number of Lines to Skip
increases the resolution.

Color Menu

Color Menu Options

The Color Menu allows you to change the Background color and Foreground color and allows
you to Invert the Background and Foreground Colors.

Background Color

This allows you to select the Background Color for your bitmap.  The following screen will
appear.  Simply choose your color and click the OK button.



   WeFax for Windows - 25

Foreground Color

This allows you to select the foreground color for your bitmap.  The following screen will appear.
Simply choose your color and click the OK button.
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Invert Colors

This command allows you to invert your Background and Foreground colors.  For instance if your
background color was white and the foreground was black then by inverting the colors, the
background would be black and the foreground would be white.  Colors are inverted when a check
mark appears beside the Invert Colors option on the Color menu.

Help Menu

Help Menu Options
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The Help menu gives you access to the WeFax for Windows Help Topics, Ordering Information,
the Registration screen, and the About WeFax box.

Help Topics

This command brings up this help file.

Ordering Information

Selecting this option brings up a dialog box that gives you contact information for questions about
ordering WeFax for Windows.
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Registration

This is where you will register your copy of WeFax for Windows.  By registering the copy, you
gain access to features not available in Demo Mode.  Enter your Call Sign, Serial Number, and
Activation Key in the appropriate boxes and click the OK button to save the Registration
information.  If you want to run WeFax for Windows in Demo Mode, enter your Call Sign and
click the Demo Mode button.  For more on Demo Mode, see the Demo Mode topic.  If you want
the Registration Screen to appear every time you start WeFax for Windows, make sure there is
check mark beside “Show this window at startup” and click OK.  To keep the Registration Screen
from appearing every time, remove the check mark and click OK.

About WeFax for Windows

The “About WeFax for Windows” box gives you copyright information as well as the version of
WeFax for Windows, the TNC you are using, and the TNC’s firmware version.
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